Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 23, 2026 - 16:40 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 23, 2026 - 16:00 CET
Scheduled
Customer Notification – Planned Maintenance Activity We are sending this communication to inform you about a planned change activity. CUSTOMER ACTION MAY BE REQUIRED Work Performed On Maintenance of the Telia IoT Connect platform database services. A configuration update will be applied to improve the handling of eSIM status information. Expected Impact
During the maintenance window: Status updates for most SIM cards (including eSIM) may be temporarily unavailable Portal access may be briefly unavailable during component restarts No impact is expected on active IoT traffic, connectivity, or live sessions Traffic disturbance is limited to SIM status updates and portal access.
Maintenance Window Start: 2026‑03‑23 16:00 CET End: 2026‑03‑23 17:30 CET
Enterprise disturbance time: During the full window Enterprise impact: Temporary unavailability of SIM status updates and a short portal interruption Worst case scenario: Extended unavailability of SIM status updates until the affected components restart successfully
Location of Works Backend systems within the Telia IoT Connect platform (database configuration update and service restarts).
Impacted Country SE
Reason for Change To improve the processing and accuracy of eSIM status information within the Telia IoT Connect platform. If you experience problems after the change, please restart your device. In case of any further problems, please log an incident in your IoT services portal. We are sorry for any inconvenience caused. Best regards, Telia