Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2025 - 09:15 CEST
Scheduled
Hello,
The 2G network in Norway will be phased out starting August 2025. This change is part of our ongoing efforts to modernize our network and improve service quality with 4G and 5G technologies.
Important dates: August 2025: Buskerud and parts of Innlandet September 2025: Telemark, Agder, and southern Rogaland October 2025: Trøndelag, Møre og Romsdal, and northern regions November 2025: Rogaland, Vestland, and Akershus December 2025: Oslo, Drammen, Vestfold, and Østfold
Your subscriptions have already been upgraded with 4G-access. If your devices support 4G, you don’t have to do anything. If you have devices that only support 2G, please upgrade to 4G or 5G compatible devices before the shutdown.
For device-related questions, your hardware supplier can support you best. For more information, check: https://www.telia.no/nett/2g-utfasing/ Thanks, Telia
Posted Aug 20, 2025 - 09:05 CEST
This scheduled maintenance affects: 2G + 3G (Norway).