Possible SMS issues
Incident Report for Telia IoT Status Portal |
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 10:44 CEST
Investigating
We are investigating possible SMS issues.
Posted Mar 30, 2024 - 16:24 CET