Temporary phone support downtime

Incident Report for Telia IoT Status Portal

Resolved

The planned telephone maintenance work has now been completed.
Posted May 13, 2025 - 22:02 CEST

Investigating

Dear user,

Due to scheduled phone maintenance, our IoT Service Desk will be unavailable for phone calls between 19:00-22:00 CET today.

If you require assistance during this time, please reach out to us via our email global-iot-support@teliacompany.com, and we will respond as soon as possible.

Thank you for your understanding.

Best regards,
Your Telia IoT Team
Posted May 13, 2025 - 18:16 CEST