Phone issues
Incident Report for Telia IoT Status Portal |
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 17:16 CEST
Investigating
Dear user,

Please be informed that we are currently experiencing issues with our phone line +46 (0) 771 100 235.
However, please note that our e-mail and ticket tools are still available.

If you have any enquiries, please reach out to our Service Desk via e-mail: Global-iot-support@teliacompany.com or via our report ticket tools in our portals.

Best regards,
Your Telia IoT Team
Posted Jun 01, 2023 - 16:38 CEST