Connectivity issues

Incident Report for Telia IoT Status Portal

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 09:18 CEST

Update

We are continuing to monitor for any further issues.
Posted Apr 02, 2025 - 09:49 CEST

Monitoring

A fix has been implemented and we are monitoring the results.

If you are still experiencing issues, please reach out to us.
You can reach us via email (global-iot-support@teliacompany.com), phone (+46 771 100 235) or by reporting an incident in our portal.

Best regards,
Your Telia IoT Team
Posted Apr 01, 2025 - 10:14 CEST

Investigating

Dear user,

Please be informed that we are currently experiencing issues in the connectivity.
We are working to identify the issue and resolve it as soon as possible.

Best regards,
Your Telia IoT Team
Posted Apr 01, 2025 - 09:33 CEST
This incident affected: 2G + 3G (Sweden, Norway, Finland, Denmark) and 4G (Sweden, Norway, Finland, Denmark).