Issues with accessing incidents in the Service Portal

Incident Report for Telia IoT Status Portal

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 22:17 CEST

Investigating

Dear user,

Please be informed that we are currently experiencing issues with accessing incidents in the Service Portal.

If you need to get in touch with us, please send an email to global-iot-support@teliacompany.com or call us at +46771100235.

Best regards,
Your Telia IoT Team
Posted Jun 04, 2025 - 21:47 CEST
This incident affected: Managed IoT Connectivity (Telia IoT Service Portal).