Telia IoT Portal Disturbance - Email Replies Affected

Incident Report for Telia IoT Status Portal

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2026 - 09:40 CET

Investigating

We are currently investigating an issue where customer replies sent via email may not appear correctly in our systems. This can result in delayed or missing communication for some support cases.

To ensure your messages are received without interruption, please submit replies directly through the Telia IoT Customer Portal:
https://oneportal.teliaiot.com/

Our team is working to identify the cause and restore normal functionality for email replies.

Updates will be provided as soon as more information is available.
Posted Feb 27, 2026 - 10:47 CET
This incident affects: Telia IoT Platform & Solutions (Telia IoT Portal).