Several components are impacted due to azure outage

Incident Report for Telia IoT Status Portal

Resolved

We could see azure front door stable for last 5hrs also one portal availability also 100%. No issues have been observed for last 5hrs.
Hence moving the ticket to resolved state.
Posted Oct 30, 2025 - 05:38 CET

Monitoring

Current Status :
We would like to inform you that the Azure global outage ( AFD ) issue has now been almost resolved.

The One-Portal is now running with 100% availability.

We have not received any intermittent alerts for nearly 2 hours—indicating that the issue has been effectively mitigated.

We will continue to closely monitor the Azure Portal and associated resources over the next few hours to ensure complete stability. A final update will be provided shortly once we confirm full resolution and sustained service health.
Posted Oct 30, 2025 - 01:49 CET

Identified

Current status:
Microsoft initiated the deployment of our ‘last known good’ configuration, which has now successfully completed. We are currently recovering nodes and re-routing traffic through healthy nodes.

We can see that the One-Portal health is gradually recovering. As the recovery progresses, some requests may still be routed to unhealthy nodes, which could result in intermittent failures or alerts until more nodes are fully restored.

This recovery effort involves reloading configurations and rebalancing traffic across a large volume of nodes to restore full operational scale. We expect continued improvement across affected regions.

Customer configuration changes remain temporarily blocked to prevent new deployments that could interfere with recovery. We will notify once this block has been lifted.

Full recovery and mitigation expect to happen by 23:20 UTC on 29 October 2025.
Posted Oct 29, 2025 - 23:33 CET

Update

Current Status :

Traffic rerouting and node recovery are ongoing. Microsoft expects full mitigation within the next few hours, but intermittent issues may persist.

Customer configuration changes will remain temporarily blocked while we continue mitigation efforts. We will notify customers once this block has been lifted.

At this stage, Microsoft anticipate full mitigation within the next four hours as we continue to recover nodes.
This means we expect recovery to happen by 23:20 UTC on 29 October 2025.
Posted Oct 29, 2025 - 22:00 CET

Update

Current Status :
We would like to share an update regarding the ongoing Azure outage impacting the Portal and Azure Front Door (AFD) services.
Microsoft has deployed the 'last known good' configuration, and recovery is currently in progress. Node restoration and traffic routing through healthy nodes are underway, with continued improvements expected.

Please note that customer configuration changes remain temporarily blocked during this mitigation phase. Azure Portal access has been rerouted and is largely functional, though some endpoints (such as Marketplace) may still experience intermittent issues.

We continue to monitor the situation closely and will keep you informed of any significant updates.
Posted Oct 29, 2025 - 20:39 CET

Update

Azure Front Door (AFD) is experiencing service disruptions due to an unintended config change.
Microsoft has blocked all AFD changes and is rolling back to a stable state.
Posted Oct 29, 2025 - 19:26 CET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 18:27 CET

Update

We are experiencing issues with https://oneportal.teliaiot.com
Posted Oct 29, 2025 - 18:18 CET

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 18:02 CET
This incident affected: IoT User Interfaces (Telia IoT Portal) and IoT Solution (IoT Platform).