Telia IoT Connectivity: Investigating Issues with connectivity

Incident Report for Telia IoT Status Portal

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 22:13 CEST

Monitoring

After investigation, packet loss was identified on a data link. Data traffic was moved to redundant link and this resolved the issue. Telia continues to monitor and investigate with these partners on the root cause for the packet loss.
Posted Aug 07, 2026 - 20:26 CEST

Update

We are continuing to investigate this issue. Our teams are still actively working to restore normal service as quickly as possible.
Posted Aug 07, 2026 - 18:59 CEST

Update

We are continuing to investigate this issue.
Posted Aug 07, 2026 - 17:36 CEST

Update

We are continuing to investigate this issue.
Posted Aug 07, 2026 - 15:53 CEST

Investigating

We are currently investigating an issue affecting our connectivity.

Impact: Users may experience issues such as packet loss, slow connection and/or reconnecting devices.

Our team is actively investigating and working to restore normal service as quickly as possible.

Workaround: There is no known workaround at this time.

Next update: We will provide another update by 15:15 CEST.

If you continue to experience issues, please log an incident in your portal for IoT services.
Posted Aug 07, 2026 - 14:20 CEST
This incident affected: Telia IoT Connectivity Services (2G & 3G, 4G, LTE-M, NB-IoT).