Support not reachable via phone

Incident Report for Telia IoT Status Portal

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 22:04 CET

Investigating

Dear user,

Due to scheduled phone maintenance, our IoT Service Desk will be unavailable for phone calls until 23:00 CET today.

If you require assistance during this time, please reach out to us via our email global-iot-support@teliacompany.com, and we will respond as soon as possible.

Thank you for your understanding.

Best regards,
Your Telia IoT Team
Posted Feb 10, 2026 - 20:36 CET