Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 14:24 CET
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 14:22 CET
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 14:18 CET
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 14:17 CET
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 14:05 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2026 - 13:58 CET
Scheduled
We are sending this communication to inform you about a planned change activity.
CUSTOMER ACTION MAY BE REQUIRED
Work Performed On Maintenance of the Telia IoT Connect platform authentication server. This work is part of improving how customers log in and authenticate to our IoT Connect services.
Expected Impact During the maintenance window: Portal logins will be unavailable Services requiring authentication may be temporarily inaccessible The platform will be unable to display the online/offline status of SIMs, and their activity history will temporarily stop updating. All ongoing IoT device traffic, SIM connectivity, and active sessions will continue to work normally. No impact is expected on online traffic or device communication. Traffic disturbance is limited only to authentication and portal access.
Maintenance Window Start: 2026‑03‑17 14:00 CET End: 2026‑03‑17 18:00 CET Estimated downtime: ~4 hours Enterprise disturbance time: During the full downtime Enterprise impact: Customers cannot log in to portals; authentication-dependent services may be unavailable, online/offline status of SIMs, and their activity history will temporarily stop updating. Worst case scenario: Extended login unavailability until the authentication service is restarted
Location of Works Telia IoT Connect backend systems (authentication service). Impacted Countries SE
Reason for Change Update and improve the authentication system to support a new login flow, enhanced security, and integration with Telia’s identity management service.
If you experience problems after the change, please restart your device. In case of any further problems, please log an incident in your IoT services portal. We are sorry for any inconvenience caused.