IoT Support Phone Issue
Incident Report for Telia IoT Status Portal |
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 16:59 CET
Investigating
Dear user,

Please be informed that we are currently experiencing issues with our support phone line.
We are working to solve this as quickly as possible.

We can still receive and handle incidents, questions and other enquiries through our portals and via our email:
Global-IoT-Support@teliacompany.com

Best regards
Your Telia IoT Team
Posted Jan 25, 2023 - 13:37 CET